summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 09:21:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 09:24:15 +0100
commitc9751d1cbe57d91a4757a0a78d12c9c941bec856 (patch)
tree90219e28e46db241dbab449707397eeb91d69a8b /dev-ros/imu_processors/imu_processors-0.2.2.ebuild
parentros-meta/rqt_robot_plugins: Bump to 0.5.6. (diff)
downloadgentoo-c9751d1cbe57d91a4757a0a78d12c9c941bec856.tar.gz
gentoo-c9751d1cbe57d91a4757a0a78d12c9c941bec856.tar.bz2
gentoo-c9751d1cbe57d91a4757a0a78d12c9c941bec856.zip
dev-ros/imu_processors: Bump to 0.2.2.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/imu_processors/imu_processors-0.2.2.ebuild')
-rw-r--r--dev-ros/imu_processors/imu_processors-0.2.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/imu_processors/imu_processors-0.2.2.ebuild b/dev-ros/imu_processors/imu_processors-0.2.2.ebuild
new file mode 100644
index 000000000000..6f04f4828067
--- /dev/null
+++ b/dev-ros/imu_processors/imu_processors-0.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Processors for sensor_msgs::Imu data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"