summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-28 17:00:54 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-28 21:13:17 +0100
commitf11b27a66d12db7b5affe950849caba8d3d0a6c7 (patch)
treef64cd70e9803637a70ab5bcdac555af84581541f /dev-ros/joint_state_publisher/joint_state_publisher-1.12.7.ebuild
parentdev-ros/collada_urdf: Bump to 1.12.7. (diff)
downloadgentoo-f11b27a66d12db7b5affe950849caba8d3d0a6c7.tar.gz
gentoo-f11b27a66d12db7b5affe950849caba8d3d0a6c7.tar.bz2
gentoo-f11b27a66d12db7b5affe950849caba8d3d0a6c7.zip
dev-ros/joint_state_publisher: Bump to 1.12.7.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-1.12.7.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.7.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.7.ebuild
new file mode 100644
index 000000000000..d9e7b8fda496
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"