summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 20:55:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 20:57:05 +0200
commit84bbb4c13fa56be2bdd496a612850b52bb17849a (patch)
treea8578a84664ede4db40d0731261873a701acf570 /dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
parentdev-ros/collada_urdf: Initial import. Ebuild by me. (diff)
downloadgentoo-84bbb4c13fa56be2bdd496a612850b52bb17849a.tar.gz
gentoo-84bbb4c13fa56be2bdd496a612850b52bb17849a.tar.bz2
gentoo-84bbb4c13fa56be2bdd496a612850b52bb17849a.zip
dev-ros/joint_state_publisher: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
new file mode 100644
index 000000000000..c536693a99c1
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${PYTHON_USEDEP}]
+"