summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 17:06:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 18:30:48 +0200
commit411fe727b1d6ddccca9f02bf212da72066e9f33a (patch)
treec2e56976139ebb4c396293c515d8cbd5c613109d /dev-ros/mavros
parentdev-ros/libmavconn: Bump to 1.2.0. (diff)
downloadgentoo-411fe727b1d6ddccca9f02bf212da72066e9f33a.tar.gz
gentoo-411fe727b1d6ddccca9f02bf212da72066e9f33a.tar.bz2
gentoo-411fe727b1d6ddccca9f02bf212da72066e9f33a.zip
dev-ros/mavros: Bump to 1.2.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/mavros')
-rw-r--r--dev-ros/mavros/Manifest1
-rw-r--r--dev-ros/mavros/mavros-1.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/mavros/Manifest b/dev-ros/mavros/Manifest
index a4182b3b8785..1cdc08cfd747 100644
--- a/dev-ros/mavros/Manifest
+++ b/dev-ros/mavros/Manifest
@@ -1 +1,2 @@
DIST mavros-0.19.0.tar.gz 219739 BLAKE2B 4e9a47fa4cdbf11b530bdc39a8048b1834689039af3005d30ffcc2b626651612db12ecc1929ecaf994c5a887224bcf2b0469d1e15ed5b353be4132fb0f523a96 SHA512 87b1b77505d3606196d609a016bcb89b3831e982f8352a13f69f5c2580f46ac603edb2d3c2ce4df5cdd1424172145b88d2b35d149c2be507eb0f23039e7e45a7
+DIST mavros-1.2.0.tar.gz 309704 BLAKE2B 85fa9079e6e26a5507878a092f671dfc387f52c65b9d1b2ba1f66d98439369550807b8afe3c99e276725b0c14d479eb1df2bd75870f2b78fe6e95c6020355cc9 SHA512 b37e3713ab15bdac23e88f3e7111821c7eaaaa263d7354852a18dd1e9f6f782a2e9450b29264536b8d712ab04021ddd84d82deeb932715d8e486dc019bb6f374
diff --git a/dev-ros/mavros/mavros-1.2.0.ebuild b/dev-ros/mavros/mavros-1.2.0.ebuild
new file mode 100644
index 000000000000..06d13ec84a26
--- /dev/null
+++ b/dev-ros/mavros/mavros-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavlink-gbp-release-2016.11.11
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"