summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:31:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:36 +0200
commita0d9892356b87010c8cfa8dd0aecbe2aa358bc88 (patch)
treebf3693456f1a1a7aa4a7a6e3324174c4473a2306 /dev-ros/move_base
parentdev-ros/map_server: Bump to 1.17.1. (diff)
downloadgentoo-a0d9892356b87010c8cfa8dd0aecbe2aa358bc88.tar.gz
gentoo-a0d9892356b87010c8cfa8dd0aecbe2aa358bc88.tar.bz2
gentoo-a0d9892356b87010c8cfa8dd0aecbe2aa358bc88.zip
dev-ros/move_base: Bump to 1.17.1.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/move_base')
-rw-r--r--dev-ros/move_base/Manifest1
-rw-r--r--dev-ros/move_base/move_base-1.17.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ros/move_base/Manifest b/dev-ros/move_base/Manifest
index a4fee98c8c5a..494e2eda7805 100644
--- a/dev-ros/move_base/Manifest
+++ b/dev-ros/move_base/Manifest
@@ -1 +1,2 @@
DIST navigation-1.17.0.tar.gz 347660 BLAKE2B 8345dccf8ac5e24d1017631bb621ebaa472cc492d6361f29938501a149555771e03a6a46e16fdcc508bbe5c206ead80e9b79e9168b873685fca50a78ea7a7e13 SHA512 a536c8826bd88151ff8f51f83661282f8ccf1b19872bd91ed32987ef372797b94489380262e79ee2560ecb4d9e290c5b4f8d52c17721e2a41126eaea909bce26
+DIST navigation-1.17.1.tar.gz 349192 BLAKE2B 4cb946a296ab53d7196a70c66cc1dda0cf62f5f279fe020ca7c39781ecb5402af6addcd6164ab6e0a9bcfe3ba26e42f647546280f03b572202f0f4df8d6ed3cf SHA512 23178adaef9b720c644f621c67ed579be312101e70a7d12b527164c5cc55286982c99149a521a76c6dda05248e859435e51f9a0f09e582b89aed3b7c2173cfaa
diff --git a/dev-ros/move_base/move_base-1.17.1.ebuild b/dev-ros/move_base/move_base-1.17.1.ebuild
new file mode 100644
index 000000000000..eaf209fa0834
--- /dev/null
+++ b/dev-ros/move_base/move_base-1.17.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ >=dev-ros/costmap_2d-1.15.1
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_ros
+
+ dev-ros/base_local_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+
+ dev-cpp/eigen:3
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/cmake_modules"