summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:17:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:17:59 +0200
commit706008c5592fd9a3a63362de2c7de8be8f7bd1d0 (patch)
treeb042b10c3260bdd27091561e28a56556b190031a /dev-ros/moveit_msgs
parentdev-ros/octomap_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-706008c5592fd9a3a63362de2c7de8be8f7bd1d0.tar.gz
gentoo-706008c5592fd9a3a63362de2c7de8be8f7bd1d0.tar.bz2
gentoo-706008c5592fd9a3a63362de2c7de8be8f7bd1d0.zip
dev-ros/moveit_msgs: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/moveit_msgs')
-rw-r--r--dev-ros/moveit_msgs/Manifest1
-rw-r--r--dev-ros/moveit_msgs/metadata.xml5
-rw-r--r--dev-ros/moveit_msgs/moveit_msgs-0.6.1.ebuild30
-rw-r--r--dev-ros/moveit_msgs/moveit_msgs-9999.ebuild30
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ros/moveit_msgs/Manifest b/dev-ros/moveit_msgs/Manifest
new file mode 100644
index 000000000000..df0dc43d95be
--- /dev/null
+++ b/dev-ros/moveit_msgs/Manifest
@@ -0,0 +1 @@
+DIST moveit_msgs-0.6.1.tar.gz 16540 SHA256 833e005ecb7bf631fb6b8e6d245739e4bdb626522b75f531cadd730ff67295f1 SHA512 a949e6c71f823b77989241f040d405ca70b0bc560661de83bebadb439e0105f36fbf0fdb36b2365847012deac05a6b21633c0190f21b24ab04facc5d87184e14 WHIRLPOOL 4e668c0961668c2266fe713c312244a48d53c322c87a7713aa39163454aa2612a7b7f4492630f9f08d35e15ab98bb8a15710d9daebc8b9a8765128d44d163bff
diff --git a/dev-ros/moveit_msgs/metadata.xml b/dev-ros/moveit_msgs/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/moveit_msgs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/moveit_msgs/moveit_msgs-0.6.1.ebuild b/dev-ros/moveit_msgs/moveit_msgs-0.6.1.ebuild
new file mode 100644
index 000000000000..1a0bf19f0eb5
--- /dev/null
+++ b/dev-ros/moveit_msgs/moveit_msgs-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/moveit_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="
+ dev-ros/actionlib_msgs
+ dev-ros/sensor_msgs
+ dev-ros/geometry_msgs
+ dev-ros/trajectory_msgs
+ dev-ros/shape_msgs
+ dev-ros/std_msgs
+ dev-ros/octomap_msgs
+ dev-ros/object_recognition_msgs
+"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages, services and actions used by MoveIt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/moveit_msgs/moveit_msgs-9999.ebuild b/dev-ros/moveit_msgs/moveit_msgs-9999.ebuild
new file mode 100644
index 000000000000..1a0bf19f0eb5
--- /dev/null
+++ b/dev-ros/moveit_msgs/moveit_msgs-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/moveit_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="
+ dev-ros/actionlib_msgs
+ dev-ros/sensor_msgs
+ dev-ros/geometry_msgs
+ dev-ros/trajectory_msgs
+ dev-ros/shape_msgs
+ dev-ros/std_msgs
+ dev-ros/octomap_msgs
+ dev-ros/object_recognition_msgs
+"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages, services and actions used by MoveIt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"