summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:33:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:38 +0200
commita9d9410e8b4098f870b67ab699447f5bbb9402b1 (patch)
tree82fa61b3756ebb636d166df74c06d6e3039d31b8 /dev-ros/pr2_description
parentdev-ros/pr2_dashboard_aggregator: Bump to 1.13.0. (diff)
downloadgentoo-a9d9410e8b4098f870b67ab699447f5bbb9402b1.tar.gz
gentoo-a9d9410e8b4098f870b67ab699447f5bbb9402b1.tar.bz2
gentoo-a9d9410e8b4098f870b67ab699447f5bbb9402b1.zip
dev-ros/pr2_description: Bump to 1.13.0.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/pr2_description')
-rw-r--r--dev-ros/pr2_description/Manifest1
-rw-r--r--dev-ros/pr2_description/pr2_description-1.13.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/pr2_description/Manifest b/dev-ros/pr2_description/Manifest
index 5000a4672af8..9a911889852b 100644
--- a/dev-ros/pr2_description/Manifest
+++ b/dev-ros/pr2_description/Manifest
@@ -1 +1,2 @@
DIST pr2_common-1.12.4.tar.gz 33597360 BLAKE2B 0591c2842720015b6a1ecbbe4fd01b4b0a4d9e2cc07641dabe024b998772f6c963c1bfa73b90d63520da425c9833e49a5c3d58785bf569d86819408616b3c3d0 SHA512 35bd91fdb296b3704f026a1e65d5bf014ce040819b0258210922898348bb8e18d5acacc59a947cadcc7266b7c83a7852f57e12a799a788cc790e434c5192f011
+DIST pr2_common-1.13.0.tar.gz 21741522 BLAKE2B a8488526aa8f059a5f3aa9e43cb30600c610a2a63d6689a32e14c39e6077c6ce2411f29ff273d00864970491cf7fab76fd94de3dc5b94bc1a12199c11aa8fe44 SHA512 c62f5c9de1d7bfaa138510633ae16a6255fadd90ae019fab203eedeb1914858287c91d0ffde287ef4df4f7245c6548ccad400ffcc94b342a1f22aec014035bc5
diff --git a/dev-ros/pr2_description/pr2_description-1.13.0.ebuild b/dev-ros/pr2_description/pr2_description-1.13.0.ebuild
new file mode 100644
index 000000000000..6b8e630a5696
--- /dev/null
+++ b/dev-ros/pr2_description/pr2_description-1.13.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Description (mechanical, kinematic, visual, etc.) of the PR2 robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/xacro[${PYTHON_SINGLE_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/urdfdom
+ dev-cpp/gtest
+ dev-ros/rosbash
+ )"
+BDEPEND="
+ dev-ros/convex_decomposition
+ dev-ros/ivcon
+"
+
+src_test() {
+ # Needed for tests to find internal launch file
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}