summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:08:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:12:08 +0200
commit0171f2627689bc308b315de85a2b554169d828b3 (patch)
tree9a6608b87712e916bb2f51463aba7d4ed8a5ea52 /dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild
parentdev-ros/qt_dotgraph: Initial import. Ebuild by me. (diff)
downloadgentoo-0171f2627689bc308b315de85a2b554169d828b3.tar.gz
gentoo-0171f2627689bc308b315de85a2b554169d828b3.tar.bz2
gentoo-0171f2627689bc308b315de85a2b554169d828b3.zip
dev-ros/qt_gui_app: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild')
-rw-r--r--dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild b/dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild
new file mode 100644
index 000000000000..d0231cff11d5
--- /dev/null
+++ b/dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"