summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-07 15:57:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-07 17:48:56 +0200
commitea4fcef768eb4fbdaf58ca2bd8826ad305d89d4d (patch)
tree56712d78404833d724690dc8c04d04d09673bbfd /dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.10.ebuild
parentdev-ros/qt_gui_cpp: Bump to 0.3.10. (diff)
downloadgentoo-ea4fcef768eb4fbdaf58ca2bd8826ad305d89d4d.tar.gz
gentoo-ea4fcef768eb4fbdaf58ca2bd8826ad305d89d4d.tar.bz2
gentoo-ea4fcef768eb4fbdaf58ca2bd8826ad305d89d4d.zip
dev-ros/qt_gui_py_common: Bump to 0.3.10.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.10.ebuild')
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.10.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.10.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.10.ebuild
new file mode 100644
index 000000000000..249bfcd6004e
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"