summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-03 12:00:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-03 12:00:29 +0200
commita68e5d8d7ab9dd9cdf6d9f94731386599d699cc3 (patch)
tree33f18263b20d30ae2df4e9809574c4e1a224a86b /dev-ros/robot_state_publisher/robot_state_publisher-1.13.2-r1.ebuild
parentdev-ros/robot_state_publisher: remove old (diff)
downloadgentoo-a68e5d8d7ab9dd9cdf6d9f94731386599d699cc3.tar.gz
gentoo-a68e5d8d7ab9dd9cdf6d9f94731386599d699cc3.tar.bz2
gentoo-a68e5d8d7ab9dd9cdf6d9f94731386599d699cc3.zip
dev-ros/robot_state_publisher: fix build with urdfdom1. Bug #590376
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/robot_state_publisher/robot_state_publisher-1.13.2-r1.ebuild')
-rw-r--r--dev-ros/robot_state_publisher/robot_state_publisher-1.13.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/robot_state_publisher/robot_state_publisher-1.13.2-r1.ebuild b/dev-ros/robot_state_publisher/robot_state_publisher-1.13.2-r1.ebuild
new file mode 100644
index 000000000000..65b8df8cc3fc
--- /dev/null
+++ b/dev-ros/robot_state_publisher/robot_state_publisher-1.13.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_state_publisher"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Package for publishing the state of a robot to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/kdl_parser
+ dev-cpp/eigen:3
+ sci-libs/orocos_kdl
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/tf2_ros
+ dev-ros/tf2_kdl
+ dev-ros/kdl_conversions
+ dev-ros/sensor_msgs
+ dev-ros/tf
+ >=dev-ros/urdf-1.12.3-r1
+"
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+PATCHES=( "${FILESDIR}/urdfdom1.patch" )
+
+src_configure() {
+ append-cxxflags -std=gnu++11
+ ros-catkin_src_configure
+}