summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-21 12:46:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-21 15:47:07 +0200
commit68d2718ec44bfe880ce4a6889f2ed18dddd0f54a (patch)
tree845287fbacd66090a14f792ed41de12cbefbe94f /dev-ros/rosapi
parentdev-python/catkin_pkg: improve catkin prefix patch not to require cmake (diff)
downloadgentoo-68d2718ec44bfe880ce4a6889f2ed18dddd0f54a.tar.gz
gentoo-68d2718ec44bfe880ce4a6889f2ed18dddd0f54a.tar.bz2
gentoo-68d2718ec44bfe880ce4a6889f2ed18dddd0f54a.zip
dev-ros/rosapi: Bump to 0.11.10.
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosapi')
-rw-r--r--dev-ros/rosapi/Manifest1
-rw-r--r--dev-ros/rosapi/rosapi-0.11.10.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosapi/Manifest b/dev-ros/rosapi/Manifest
index ae35be42cc80..c29284bcfc75 100644
--- a/dev-ros/rosapi/Manifest
+++ b/dev-ros/rosapi/Manifest
@@ -1 +1,2 @@
+DIST rosbridge_suite-0.11.10.tar.gz 112955 BLAKE2B 82d9ee61d57876795a14b425d5037ac811d8fa7eed46be4a792244582dc620107973ad5bb05f5131618b124e2624a4e54047f795771be0a79de28a8d003f0a6d SHA512 0bd038792c75e451e92a242724a104a0e2e16d807e300db88317a4093a783813c218ebd76793c77352ba3c8155451cd20cb7154cf957ef22e821f4e76d37e88d
DIST rosbridge_suite-0.11.9.tar.gz 112209 BLAKE2B 7c874b397f8bf4f5d131e6ec40c6940e0648a0a401d270172b328cb0207b4d3974a37ebb776fc219adbbb77c24a8e77e20b24a93dc2edb3b41e157908648ed68 SHA512 a46aff0ca8b31a08f45c73af89296000d285cb6ca53587b0c2c0bd55c4a43bec2c86c4937082b59e2b6bd78793a3a2a1762aebc1223af0e1ba0d1c18f7d50963
diff --git a/dev-ros/rosapi/rosapi-0.11.10.ebuild b/dev-ros/rosapi/rosapi-0.11.10.ebuild
new file mode 100644
index 000000000000..1f0478a2bcae
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.11.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Service calls for getting ros meta-information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbridge_library[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosnode[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"