summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:10:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:45 +0200
commit2e45b805dea200e3a2f191b9f0792abfa30e00b9 (patch)
tree2fc09bb0af04892dbba470a76c2e13fb4eadc789 /dev-ros/rosbag/rosbag-1.13.1.ebuild
parentdev-ros/message_filters: Bump to 1.13.1. (diff)
downloadgentoo-2e45b805dea200e3a2f191b9f0792abfa30e00b9.tar.gz
gentoo-2e45b805dea200e3a2f191b9f0792abfa30e00b9.tar.bz2
gentoo-2e45b805dea200e3a2f191b9f0792abfa30e00b9.zip
dev-ros/rosbag: Bump to 1.13.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rosbag/rosbag-1.13.1.ebuild')
-rw-r--r--dev-ros/rosbag/rosbag-1.13.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rosbag/rosbag-1.13.1.ebuild b/dev-ros/rosbag/rosbag-1.13.1.ebuild
new file mode 100644
index 000000000000..cdf7eefd0a90
--- /dev/null
+++ b/dev-ros/rosbag/rosbag-1.13.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back to ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE="lz4"
+
+RDEPEND="
+ dev-ros/rosbag_storage
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/topic_tools
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+ app-arch/bzip2
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/genpy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"