summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:40:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:26 +0200
commitc935d71338f434e3bbc460e04f22de87f2a2ef40 (patch)
treeca29a9ca137c67922291562fc6c8a3c7bbf33133 /dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
parentdev-ros/message_filters: Initial import. Ebuild by me. (diff)
downloadgentoo-c935d71338f434e3bbc460e04f22de87f2a2ef40.tar.gz
gentoo-c935d71338f434e3bbc460e04f22de87f2a2ef40.tar.bz2
gentoo-c935d71338f434e3bbc460e04f22de87f2a2ef40.zip
dev-ros/rosbag_storage: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosbag_storage/rosbag_storage-9999.ebuild')
-rw-r--r--dev-ros/rosbag_storage/rosbag_storage-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild b/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
new file mode 100644
index 000000000000..ebb742bf256e
--- /dev/null
+++ b/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back ROS message"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/console_bridge
+ dev-ros/cpp_common
+ dev-ros/roscpp_serialization
+ dev-ros/roscpp_traits
+ dev-ros/rostime
+ dev-ros/roslz4
+ dev-libs/boost:=
+ app-arch/bzip2
+"
+DEPEND="${RDEPEND}"