summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-15 17:12:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-15 17:35:51 +0200
commit7281c8da8fc739df880b89152acc99eddff25c2f (patch)
tree9c9637b1a4501135a570461d1ed9d40e772c721d /dev-ros/rosbridge_library
parentdev-ros/rosbridge_server: update live ebuild (diff)
downloadgentoo-7281c8da8fc739df880b89152acc99eddff25c2f.tar.gz
gentoo-7281c8da8fc739df880b89152acc99eddff25c2f.tar.bz2
gentoo-7281c8da8fc739df880b89152acc99eddff25c2f.zip
dev-ros/rosbridge_library: update live ebuild
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbridge_library')
-rw-r--r--dev-ros/rosbridge_library/rosbridge_library-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild b/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild
index 9ebd079262d5..8436b3242e6d 100644
--- a/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild
+++ b/dev-ros/rosbridge_library/rosbridge_library-9999.ebuild
@@ -1,34 +1,34 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
inherit ros-catkin
-DESCRIPTION="Core rosbridge package responsible for interpreting JSON and performing the appropriate ROS action"
+DESCRIPTION="Core rosbridge package for parsing JSON and performing the appropriate action"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
dev-ros/rosservice[${PYTHON_USEDEP}]
dev-ros/rostopic[${PYTHON_USEDEP}]
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pymongo[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/cbor[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pymongo[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]