summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-06 12:44:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-06 13:12:51 +0200
commit27dfa464cbd56b411389e0c845e6d5bef520f7d9 (patch)
tree7359ef61aaa3ac15e6265e1091327537bf2f4de2 /dev-ros/rosgraph/rosgraph-1.12.2.ebuild
parentdev-ros/rosconsole: Bump to 1.12.2. (diff)
downloadgentoo-27dfa464cbd56b411389e0c845e6d5bef520f7d9.tar.gz
gentoo-27dfa464cbd56b411389e0c845e6d5bef520f7d9.tar.bz2
gentoo-27dfa464cbd56b411389e0c845e6d5bef520f7d9.zip
dev-ros/rosgraph: Bump to 1.12.2.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.12.2.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.12.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.12.2.ebuild b/dev-ros/rosgraph/rosgraph-1.12.2.ebuild
new file mode 100644
index 000000000000..35e83567c401
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.12.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"