summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-22 17:09:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-22 17:25:15 +0200
commitcc6884e55fbc6cdd0dcf6afe5e8a5312facc9303 (patch)
tree02a9ab1dbf6bc89f030e500c426e72878573539b /dev-ros/rosmake/rosmake-1.13.4.ebuild
parentdev-ros/roscreate: Bump to 1.13.4. (diff)
downloadgentoo-cc6884e55fbc6cdd0dcf6afe5e8a5312facc9303.tar.gz
gentoo-cc6884e55fbc6cdd0dcf6afe5e8a5312facc9303.tar.bz2
gentoo-cc6884e55fbc6cdd0dcf6afe5e8a5312facc9303.zip
dev-ros/rosmake: Bump to 1.13.4.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rosmake/rosmake-1.13.4.ebuild')
-rw-r--r--dev-ros/rosmake/rosmake-1.13.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosmake/rosmake-1.13.4.ebuild b/dev-ros/rosmake/rosmake-1.13.4.ebuild
new file mode 100644
index 000000000000..5de0ba1efee7
--- /dev/null
+++ b/dev-ros/rosmake/rosmake-1.13.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS dependency aware build tool"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"