summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 10:50:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:07:36 +0200
commit2a68e5996b66f1acc76e53a3fec4ce831805c740 (patch)
tree84df2458ecffe33cbf03d14404c581a73ea7a206 /dev-ros/rosmaster/rosmaster-1.12.1.ebuild
parentdev-ros/roslaunch: Bump to 1.12.1. (diff)
downloadgentoo-2a68e5996b66f1acc76e53a3fec4ce831805c740.tar.gz
gentoo-2a68e5996b66f1acc76e53a3fec4ce831805c740.tar.bz2
gentoo-2a68e5996b66f1acc76e53a3fec4ce831805c740.zip
dev-ros/rosmaster: Bump to 1.12.1.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/rosmaster/rosmaster-1.12.1.ebuild')
-rw-r--r--dev-ros/rosmaster/rosmaster-1.12.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosmaster/rosmaster-1.12.1.ebuild b/dev-ros/rosmaster/rosmaster-1.12.1.ebuild
new file mode 100644
index 000000000000..ec8fb4f31a65
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-1.12.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"