summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-03 11:37:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-03 13:10:51 +0200
commitf3ff04ec4651776d1ad8c707bfd65aa5fc10b16a (patch)
tree2674f3157c2b1b06ae1d07ffa3568148a97cb7d7 /dev-ros/rosmaster/rosmaster-1.12.5.ebuild
parentdev-ros/roslaunch: Bump to 1.12.5. (diff)
downloadgentoo-f3ff04ec4651776d1ad8c707bfd65aa5fc10b16a.tar.gz
gentoo-f3ff04ec4651776d1ad8c707bfd65aa5fc10b16a.tar.bz2
gentoo-f3ff04ec4651776d1ad8c707bfd65aa5fc10b16a.zip
dev-ros/rosmaster: Bump to 1.12.5.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rosmaster/rosmaster-1.12.5.ebuild')
-rw-r--r--dev-ros/rosmaster/rosmaster-1.12.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosmaster/rosmaster-1.12.5.ebuild b/dev-ros/rosmaster/rosmaster-1.12.5.ebuild
new file mode 100644
index 000000000000..eead19bc033d
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-1.12.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"