summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 15:02:27 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 15:47:00 +0100
commite06829421b2197fab42d532afbe4123fd920d585 (patch)
tree35f598b6b552eff436caa15ac384245b467f0781 /dev-ros/rosmsg/rosmsg-1.14.3-r1.ebuild
parentdev-ros/rosmsg: Remove old (diff)
downloadgentoo-e06829421b2197fab42d532afbe4123fd920d585.tar.gz
gentoo-e06829421b2197fab42d532afbe4123fd920d585.tar.bz2
gentoo-e06829421b2197fab42d532afbe4123fd920d585.zip
dev-ros/rosmsg: upstream py3 fixes
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.14.3-r1.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.14.3-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.14.3-r1.ebuild b/dev-ros/rosmsg/rosmsg-1.14.3-r1.ebuild
new file mode 100644
index 000000000000..6cb2aaadabab
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.14.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/py3.patch" )