summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-13 13:24:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-13 16:07:05 +0200
commit7cfb974ea1f71fada7253bb171816816f22051db (patch)
tree92d0d5b76ab9763db349172e20ef8f00cfce9304 /dev-ros/rosmsg/rosmsg-1.15.4.ebuild
parentdev-ros/rosmaster: Bump to 1.15.4. (diff)
downloadgentoo-7cfb974ea1f71fada7253bb171816816f22051db.tar.gz
gentoo-7cfb974ea1f71fada7253bb171816816f22051db.tar.bz2
gentoo-7cfb974ea1f71fada7253bb171816816f22051db.zip
dev-ros/rosmsg: Bump to 1.15.4.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.15.4.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.15.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.15.4.ebuild b/dev-ros/rosmsg/rosmsg-1.15.4.ebuild
new file mode 100644
index 000000000000..941834eadacc
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.15.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/test_rosmaster[${PYTHON_USEDEP}] )
+"