summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 10:50:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:07:36 +0200
commit4f5455a243ef860eac638bab2290ee22190c3744 (patch)
treea68efc9849f0275ef58f0500ae50baaaade77a59 /dev-ros/rosnode/rosnode-1.12.1.ebuild
parentdev-ros/rosmsg: Bump to 1.12.1. (diff)
downloadgentoo-4f5455a243ef860eac638bab2290ee22190c3744.tar.gz
gentoo-4f5455a243ef860eac638bab2290ee22190c3744.tar.bz2
gentoo-4f5455a243ef860eac638bab2290ee22190c3744.zip
dev-ros/rosnode: Bump to 1.12.1.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/rosnode/rosnode-1.12.1.ebuild')
-rw-r--r--dev-ros/rosnode/rosnode-1.12.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosnode/rosnode-1.12.1.ebuild b/dev-ros/rosnode/rosnode-1.12.1.ebuild
new file mode 100644
index 000000000000..1d4acc8351d8
--- /dev/null
+++ b/dev-ros/rosnode/rosnode-1.12.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"