summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:15:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:24 +0200
commitd5eeca3638395eb48cedc0116af3d4c5acf67833 (patch)
tree72c99eceabddc8fd03e0eaf750ea5d550d6da1ff /dev-ros/rosout
parentdev-ros/topic_tools: Initial import. Ebuild by me. (diff)
downloadgentoo-d5eeca3638395eb48cedc0116af3d4c5acf67833.tar.gz
gentoo-d5eeca3638395eb48cedc0116af3d4c5acf67833.tar.bz2
gentoo-d5eeca3638395eb48cedc0116af3d4c5acf67833.zip
dev-ros/rosout: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosout')
-rw-r--r--dev-ros/rosout/Manifest1
-rw-r--r--dev-ros/rosout/metadata.xml5
-rw-r--r--dev-ros/rosout/rosout-1.11.14.ebuild22
-rw-r--r--dev-ros/rosout/rosout-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ros/rosout/Manifest b/dev-ros/rosout/Manifest
new file mode 100644
index 000000000000..84bda7639707
--- /dev/null
+++ b/dev-ros/rosout/Manifest
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/rosout/metadata.xml b/dev-ros/rosout/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosout/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosout/rosout-1.11.14.ebuild b/dev-ros/rosout/rosout-1.11.14.ebuild
new file mode 100644
index 000000000000..578c51b32a35
--- /dev/null
+++ b/dev-ros/rosout/rosout-1.11.14.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="System-wide logging mechanism for messages sent to the /rosout topic"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosout/rosout-9999.ebuild b/dev-ros/rosout/rosout-9999.ebuild
new file mode 100644
index 000000000000..578c51b32a35
--- /dev/null
+++ b/dev-ros/rosout/rosout-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="System-wide logging mechanism for messages sent to the /rosout topic"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"