summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-06 12:45:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-06 13:12:51 +0200
commit1187976081bc5a8d33b4643262a4718677dff514 (patch)
treede29b06c0a94bbc3ec24a8059a0a4d31c244cf84 /dev-ros/rosparam/rosparam-1.12.2.ebuild
parentdev-ros/rosout: Bump to 1.12.2. (diff)
downloadgentoo-1187976081bc5a8d33b4643262a4718677dff514.tar.gz
gentoo-1187976081bc5a8d33b4643262a4718677dff514.tar.bz2
gentoo-1187976081bc5a8d33b4643262a4718677dff514.zip
dev-ros/rosparam: Bump to 1.12.2.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/rosparam/rosparam-1.12.2.ebuild')
-rw-r--r--dev-ros/rosparam/rosparam-1.12.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosparam/rosparam-1.12.2.ebuild b/dev-ros/rosparam/rosparam-1.12.2.ebuild
new file mode 100644
index 000000000000..cd0ef7f7f262
--- /dev/null
+++ b/dev-ros/rosparam/rosparam-1.12.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for getting and setting ROS Parameters on the parameter server"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"