summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-19 14:14:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-19 14:55:38 +0100
commit2591272abfab23d1a7cd6d8c66f5ada103f536ed (patch)
tree51d600ef2f0b4b5c8e60d74b050fef668719a862 /dev-ros/rospy_tutorials/rospy_tutorials-0.7.0.ebuild
parentdev-ros/roscpp_tutorials: Bump to 0.7.0. (diff)
downloadgentoo-2591272abfab23d1a7cd6d8c66f5ada103f536ed.tar.gz
gentoo-2591272abfab23d1a7cd6d8c66f5ada103f536ed.tar.bz2
gentoo-2591272abfab23d1a7cd6d8c66f5ada103f536ed.zip
dev-ros/rospy_tutorials: Bump to 0.7.0.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rospy_tutorials/rospy_tutorials-0.7.0.ebuild')
-rw-r--r--dev-ros/rospy_tutorials/rospy_tutorials-0.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rospy_tutorials/rospy_tutorials-0.7.0.ebuild b/dev-ros/rospy_tutorials/rospy_tutorials-0.7.0.ebuild
new file mode 100644
index 000000000000..f1332470fdd1
--- /dev/null
+++ b/dev-ros/rospy_tutorials/rospy_tutorials-0.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"