summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-14 00:30:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-14 00:35:02 +0100
commit359ff2d9e1902eefb385033783b352707e8e8013 (patch)
treee64e99a3fdcebc064e7b2aa5e21e3179d96f9bde /dev-ros/rospy_tutorials/rospy_tutorials-0.8.0.ebuild
parentdev-ros/roscpp_tutorials: Bump to 0.8.0. (diff)
downloadgentoo-359ff2d9e1902eefb385033783b352707e8e8013.tar.gz
gentoo-359ff2d9e1902eefb385033783b352707e8e8013.tar.bz2
gentoo-359ff2d9e1902eefb385033783b352707e8e8013.zip
dev-ros/rospy_tutorials: Bump to 0.8.0.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rospy_tutorials/rospy_tutorials-0.8.0.ebuild')
-rw-r--r--dev-ros/rospy_tutorials/rospy_tutorials-0.8.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rospy_tutorials/rospy_tutorials-0.8.0.ebuild b/dev-ros/rospy_tutorials/rospy_tutorials-0.8.0.ebuild
new file mode 100644
index 000000000000..fb8c51aee23a
--- /dev/null
+++ b/dev-ros/rospy_tutorials/rospy_tutorials-0.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"