summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-03 11:37:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-03 13:10:52 +0200
commit5702654ad1ef8f42deb550672a240fe7a47ebefe (patch)
tree8e1f3ffa20546ef69dc7c986cebac8c0f40c7bd4 /dev-ros/rosservice/rosservice-1.12.5.ebuild
parentdev-ros/rosparam: Bump to 1.12.5. (diff)
downloadgentoo-5702654ad1ef8f42deb550672a240fe7a47ebefe.tar.gz
gentoo-5702654ad1ef8f42deb550672a240fe7a47ebefe.tar.bz2
gentoo-5702654ad1ef8f42deb550672a240fe7a47ebefe.zip
dev-ros/rosservice: Bump to 1.12.5.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rosservice/rosservice-1.12.5.ebuild')
-rw-r--r--dev-ros/rosservice/rosservice-1.12.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosservice/rosservice-1.12.5.ebuild b/dev-ros/rosservice/rosservice-1.12.5.ebuild
new file mode 100644
index 000000000000..891fbc7248a1
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.12.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"