summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-01 13:43:17 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-01 13:53:52 +0100
commit24ce692ee8e838d19fec8e5b870542073f1f5931 (patch)
tree23273e8564a4071800a8de894b87a95b08b2987c /dev-ros/rosservice/rosservice-1.12.6.ebuild
parentdev-ros/rosparam: Bump to 1.12.6. (diff)
downloadgentoo-24ce692ee8e838d19fec8e5b870542073f1f5931.tar.gz
gentoo-24ce692ee8e838d19fec8e5b870542073f1f5931.tar.bz2
gentoo-24ce692ee8e838d19fec8e5b870542073f1f5931.zip
dev-ros/rosservice: Bump to 1.12.6.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros/rosservice/rosservice-1.12.6.ebuild')
-rw-r--r--dev-ros/rosservice/rosservice-1.12.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosservice/rosservice-1.12.6.ebuild b/dev-ros/rosservice/rosservice-1.12.6.ebuild
new file mode 100644
index 000000000000..891fbc7248a1
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.12.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"