summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:02:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:42 +0200
commit72a99092d6879e01c9a5a10fcdef6f5c69bd2601 (patch)
tree4ade32d1d4559c7c4fe77004e631a67c57a50b62 /dev-ros/rostime/rostime-0.6.5.ebuild
parentdev-ros/cpp_common: Bump to 0.6.5. (diff)
downloadgentoo-72a99092d6879e01c9a5a10fcdef6f5c69bd2601.tar.gz
gentoo-72a99092d6879e01c9a5a10fcdef6f5c69bd2601.tar.bz2
gentoo-72a99092d6879e01c9a5a10fcdef6f5c69bd2601.zip
dev-ros/rostime: Bump to 0.6.5.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rostime/rostime-0.6.5.ebuild')
-rw-r--r--dev-ros/rostime/rostime-0.6.5.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rostime/rostime-0.6.5.ebuild b/dev-ros/rostime/rostime-0.6.5.ebuild
new file mode 100644
index 000000000000..ccd863194982
--- /dev/null
+++ b/dev-ros/rostime/rostime-0.6.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Time and Duration implementations for C++ libraries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/cpp_common
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"