summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-04 11:30:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-04 12:05:31 +0100
commit8e4c1e25a3b9b6f116e77377f0fa67e83e6c3dbf (patch)
treeb62e85d21884fc5a16ff119b12dc2871bf9649b9 /dev-ros/roswtf/roswtf-1.13.4.ebuild
parentdev-ros/xmlrpcpp: Bump to 1.13.4. (diff)
downloadgentoo-8e4c1e25a3b9b6f116e77377f0fa67e83e6c3dbf.tar.gz
gentoo-8e4c1e25a3b9b6f116e77377f0fa67e83e6c3dbf.tar.bz2
gentoo-8e4c1e25a3b9b6f116e77377f0fa67e83e6c3dbf.zip
dev-ros/roswtf: Bump to 1.13.4.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/roswtf/roswtf-1.13.4.ebuild')
-rw-r--r--dev-ros/roswtf/roswtf-1.13.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roswtf/roswtf-1.13.4.ebuild b/dev-ros/roswtf/roswtf-1.13.4.ebuild
new file mode 100644
index 000000000000..beab39855484
--- /dev/null
+++ b/dev-ros/roswtf/roswtf-1.13.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for diagnosing issues with a running ROS system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-util/rosdep[${PYTHON_USEDEP}]
+ dev-util/rosinstall[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"