summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:47:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:04 +0200
commit0c0281b81c0832fdc39cb129f318ee95110bbb0a (patch)
treeee01dec69e0851963047161a162e4332ff4eb157 /dev-ros/rqt_console
parentdev-ros/rqt_controller_manager: convert to python-single-r1 (diff)
downloadgentoo-0c0281b81c0832fdc39cb129f318ee95110bbb0a.tar.gz
gentoo-0c0281b81c0832fdc39cb129f318ee95110bbb0a.tar.bz2
gentoo-0c0281b81c0832fdc39cb129f318ee95110bbb0a.zip
dev-ros/rqt_console: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_console')
-rw-r--r--dev-ros/rqt_console/rqt_console-0.4.11.ebuild14
-rw-r--r--dev-ros/rqt_console/rqt_console-9999.ebuild14
2 files changed, 14 insertions, 14 deletions
diff --git a/dev-ros/rqt_console/rqt_console-0.4.11.ebuild b/dev-ros/rqt_console/rqt_console-0.4.11.ebuild
index 7804ae8e93f0..2f17c1d3201b 100644
--- a/dev-ros/rqt_console/rqt_console-0.4.11.ebuild
+++ b/dev-ros/rqt_console/rqt_console-0.4.11.ebuild
@@ -14,12 +14,12 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
- dev-ros/rqt_logger_level[${PYTHON_USEDEP}]
- >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_logger_level[${PYTHON_SINGLE_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_console/rqt_console-9999.ebuild b/dev-ros/rqt_console/rqt_console-9999.ebuild
index 7804ae8e93f0..2f17c1d3201b 100644
--- a/dev-ros/rqt_console/rqt_console-9999.ebuild
+++ b/dev-ros/rqt_console/rqt_console-9999.ebuild
@@ -14,12 +14,12 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
- dev-ros/rqt_logger_level[${PYTHON_USEDEP}]
- >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_logger_level[${PYTHON_SINGLE_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"