summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:35:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:04 +0200
commitc9434e38dc0d17d32cc687766e244e49b091e03d (patch)
tree38042575e094f8697bcc2d3a2633ceb6f38e5cfb /dev-ros/rqt_console
parentdev-ros/rqt_console: remove old (diff)
downloadgentoo-c9434e38dc0d17d32cc687766e244e49b091e03d.tar.gz
gentoo-c9434e38dc0d17d32cc687766e244e49b091e03d.tar.bz2
gentoo-c9434e38dc0d17d32cc687766e244e49b091e03d.zip
dev-ros/rqt_console: bump to 0.4.8 and update to separate repo
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_console')
-rw-r--r--dev-ros/rqt_console/Manifest1
-rw-r--r--dev-ros/rqt_console/metadata.xml2
-rw-r--r--dev-ros/rqt_console/rqt_console-0.4.8.ebuild26
-rw-r--r--dev-ros/rqt_console/rqt_console-9999.ebuild5
4 files changed, 30 insertions, 4 deletions
diff --git a/dev-ros/rqt_console/Manifest b/dev-ros/rqt_console/Manifest
index 7bb8c4d74093..ddb89b5d7931 100644
--- a/dev-ros/rqt_console/Manifest
+++ b/dev-ros/rqt_console/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_console-0.4.8.tar.gz 26946 SHA256 8c128f3d09f3baebb0999cb7c28f63689f5e415ee2cab21dc94fc3846a151564 SHA512 9674898ef33397d59554b20980c45ae4cc04be019a2f039eedd401ccd6f774e9f6e4130c1aad9bb953d39f47a971fe0514853d2be8be05cc53d6d8c203054813 WHIRLPOOL 71e425868a6fcd974835422aa0c6a497b257aa6eeede323f2c9b9451036dd776abf554e7f5c4338c3997bae5e545894412e89f10dfeff62a0a43bc0229deeae5
diff --git a/dev-ros/rqt_console/metadata.xml b/dev-ros/rqt_console/metadata.xml
index cb473d142b8e..69ded7d932cb 100644
--- a/dev-ros/rqt_console/metadata.xml
+++ b/dev-ros/rqt_console/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_console</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_console/rqt_console-0.4.8.ebuild b/dev-ros/rqt_console/rqt_console-0.4.8.ebuild
new file mode 100644
index 000000000000..eefcdaa3e26c
--- /dev/null
+++ b/dev-ros/rqt_console/rqt_console-0.4.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_console"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and filtering ROS messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_logger_level[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_console/rqt_console-9999.ebuild b/dev-ros/rqt_console/rqt_console-9999.ebuild
index c74ab1b0831e..eefcdaa3e26c 100644
--- a/dev-ros/rqt_console/rqt_console-9999.ebuild
+++ b/dev-ros/rqt_console/rqt_console-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_console"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin