summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-28 16:55:34 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-28 21:13:15 +0100
commitf21c44d10bec93f84d6a6b7d17822ea83ed2e285 (patch)
tree7a5f222881586b8dc23690a3613d65b0294a1d98 /dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild
parentdev-ros/rqt_gui_cpp: Bump to 0.3.2. (diff)
downloadgentoo-f21c44d10bec93f84d6a6b7d17822ea83ed2e285.tar.gz
gentoo-f21c44d10bec93f84d6a6b7d17822ea83ed2e285.tar.bz2
gentoo-f21c44d10bec93f84d6a6b7d17822ea83ed2e285.zip
dev-ros/rqt_gui_py: Bump to 0.3.2.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild')
-rw-r--r--dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild
new file mode 100644
index 000000000000..288ea618a49a
--- /dev/null
+++ b/dev-ros/rqt_gui_py/rqt_gui_py-0.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ >=dev-ros/rqt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"