summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 08:11:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:13 +0200
commit84c1e04f89ff50970bb7aaca62d15d9cdfbfdbe2 (patch)
tree47d13c630d20e22f1cc1492259f940db4f53c448 /dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild
parentdev-ros/rqt_gui_cpp: Bump to 0.5.0. (diff)
downloadgentoo-84c1e04f89ff50970bb7aaca62d15d9cdfbfdbe2.tar.gz
gentoo-84c1e04f89ff50970bb7aaca62d15d9cdfbfdbe2.tar.bz2
gentoo-84c1e04f89ff50970bb7aaca62d15d9cdfbfdbe2.zip
dev-ros/rqt_gui_py: Bump to 0.5.0.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild')
-rw-r--r--dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild
new file mode 100644
index 000000000000..146f59212afe
--- /dev/null
+++ b/dev-ros/rqt_gui_py/rqt_gui_py-0.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ >=dev-ros/rqt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"