summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-02 11:21:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 11:33:28 +0200
commit50d77c7e688ec4135a32f1945c1e881d456e0c32 (patch)
tree877fee479c659a23227501d153900cd4d42b86ed /dev-ros/rqt_nav_view
parentdev-ros/rqt_nav_view: remove old (diff)
downloadgentoo-50d77c7e688ec4135a32f1945c1e881d456e0c32.tar.gz
gentoo-50d77c7e688ec4135a32f1945c1e881d456e0c32.tar.bz2
gentoo-50d77c7e688ec4135a32f1945c1e881d456e0c32.zip
dev-ros/rqt_nav_view: bump to 0.5.7 and switch to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_nav_view')
-rw-r--r--dev-ros/rqt_nav_view/Manifest1
-rw-r--r--dev-ros/rqt_nav_view/metadata.xml2
-rw-r--r--dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild28
-rw-r--r--dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild5
4 files changed, 32 insertions, 4 deletions
diff --git a/dev-ros/rqt_nav_view/Manifest b/dev-ros/rqt_nav_view/Manifest
index bb0da5c3c13b..d11e43616935 100644
--- a/dev-ros/rqt_nav_view/Manifest
+++ b/dev-ros/rqt_nav_view/Manifest
@@ -1 +1,2 @@
+DIST rqt_nav_view-0.5.7.tar.gz 7261 SHA256 93ee15ffdac90401e7b7ba1386f4b5a5ee7aa9c7e7b55227b7763dc21cf0a7cc SHA512 a8c4544bc4bd11a7e2d7a60786033c82206c3e4ac822c7d72199af465c7d8488584906906b2a3e124b271171717256c1412697b1ac0dcf02c8c5bcd3faae232e WHIRLPOOL 2c80aa0f7c2bd5c83e774204ad5ad85f97858537df4d815a505f40d88c1d4f721418e10d2dca600417144d626c0b5ca33abfd052fef7ea54c67c7144318cc4ec
DIST rqt_robot_plugins-0.5.6.tar.gz 2107696 SHA256 d5f1b509df54b253d3b2952560e8dc5e764c3259b0e9dcff08541e27ac9fed71 SHA512 871f660e22afafd510e34984b94d2530bc3314db194c06ff458430e15b1183a60147289e9544a5fb070665a3c83034cbcccefe2f820e62f091c3bbc0edfd0a51 WHIRLPOOL a90882b1e762f5e53b7ce7ff92695ba8eb63242b53304a08c928f2667ceb206cfda72e64d81b73d1d951e6b92cb5f16327528846f6b54e28b2acaf898424a664
diff --git a/dev-ros/rqt_nav_view/metadata.xml b/dev-ros/rqt_nav_view/metadata.xml
index 70d1993e2855..3ffc1b2b8965 100644
--- a/dev-ros/rqt_nav_view/metadata.xml
+++ b/dev-ros/rqt_nav_view/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_robot_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_nav_view</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild b/dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild
new file mode 100644
index 000000000000..3d2eb643f259
--- /dev/null
+++ b/dev-ros/rqt_nav_view/rqt_nav_view-0.5.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_nav_view"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a gui for viewing navigation maps and paths"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild b/dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild
index dfc64d6f6098..3d2eb643f259 100644
--- a/dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild
+++ b/dev-ros/rqt_nav_view/rqt_nav_view-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_nav_view"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin