summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-17 12:06:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-17 12:21:31 +0200
commitdaa58a9171085b23fee7c825aa5a74c026a195fb (patch)
tree6814de662478ef9618d559412f050f4e4750ca15 /dev-ros/rqt_publisher/rqt_publisher-0.4.1.ebuild
parentdev-ros/rqt_plot: Bump to 0.4.1. (diff)
downloadgentoo-daa58a9171085b23fee7c825aa5a74c026a195fb.tar.gz
gentoo-daa58a9171085b23fee7c825aa5a74c026a195fb.tar.bz2
gentoo-daa58a9171085b23fee7c825aa5a74c026a195fb.zip
dev-ros/rqt_publisher: Bump to 0.4.1.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/rqt_publisher/rqt_publisher-0.4.1.ebuild')
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-0.4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/rqt_publisher/rqt_publisher-0.4.1.ebuild b/dev-ros/rqt_publisher/rqt_publisher-0.4.1.ebuild
new file mode 100644
index 000000000000..4d33a2901659
--- /dev/null
+++ b/dev-ros/rqt_publisher/rqt_publisher-0.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for publishing arbitrary messages with fixed or computed field values"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"