summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 08:11:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:14 +0200
commit42cd066cfabba6e6c657dca321e1531e4e1e25b7 (patch)
tree263cc807ee189ba2e2ada54f16fa08afb0cfc5b9 /dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild
parentdev-ros/rqt_gui_py: Bump to 0.5.0. (diff)
downloadgentoo-42cd066cfabba6e6c657dca321e1531e4e1e25b7.tar.gz
gentoo-42cd066cfabba6e6c657dca321e1531e4e1e25b7.tar.bz2
gentoo-42cd066cfabba6e6c657dca321e1531e4e1e25b7.zip
dev-ros/rqt_py_common: Bump to 0.5.0.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild')
-rw-r--r--dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild b/dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild
new file mode 100644
index 000000000000..bb0ac4b8ba23
--- /dev/null
+++ b/dev-ros/rqt_py_common/rqt_py_common-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for rqt plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"