summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-30 15:28:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-30 17:02:33 +0200
commit45b19783429594560bd571bdd9ec394cc928768a (patch)
tree85503d77b75362c4c97d3cd9fa84200c6d4c5ca8 /dev-ros/rqt_py_common
parentdev-python/spur: Add explicit RDEP on paramiko (diff)
downloadgentoo-45b19783429594560bd571bdd9ec394cc928768a.tar.gz
gentoo-45b19783429594560bd571bdd9ec394cc928768a.tar.bz2
gentoo-45b19783429594560bd571bdd9ec394cc928768a.zip
dev-ros/rqt_py_common: proper test message handling
Closes: https://bugs.gentoo.org/734712 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_py_common')
-rw-r--r--dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild8
-rw-r--r--dev-ros/rqt_py_common/rqt_py_common-9999.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild b/dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild
index 28811998d491..7f032e6025de 100644
--- a/dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild
+++ b/dev-ros/rqt_py_common/rqt_py_common-0.5.2.ebuild
@@ -6,6 +6,8 @@ EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt"
ROS_SUBDIR=${PN}
+# Tests have messages
+CATKIN_HAS_MESSAGES=yes
inherit ros-catkin
@@ -22,4 +24,8 @@ RDEPEND="
dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
>=dev-ros/python_qt_binding-0.2.19[${PYTHON_SINGLE_USEDEP}]
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
+"
diff --git a/dev-ros/rqt_py_common/rqt_py_common-9999.ebuild b/dev-ros/rqt_py_common/rqt_py_common-9999.ebuild
index 28811998d491..7f032e6025de 100644
--- a/dev-ros/rqt_py_common/rqt_py_common-9999.ebuild
+++ b/dev-ros/rqt_py_common/rqt_py_common-9999.ebuild
@@ -6,6 +6,8 @@ EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt"
ROS_SUBDIR=${PN}
+# Tests have messages
+CATKIN_HAS_MESSAGES=yes
inherit ros-catkin
@@ -22,4 +24,8 @@ RDEPEND="
dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
>=dev-ros/python_qt_binding-0.2.19[${PYTHON_SINGLE_USEDEP}]
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
+"