summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:37:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:56 +0200
commit09b71b1681699091d117af85ff59260cefc53c6d (patch)
tree59e24eb80fb54c8c2e089697c21f119f3712389b /dev-ros/rqt_topic
parentdev-ros/rqt_srv: convert to python-single-r1 (diff)
downloadgentoo-09b71b1681699091d117af85ff59260cefc53c6d.tar.gz
gentoo-09b71b1681699091d117af85ff59260cefc53c6d.tar.bz2
gentoo-09b71b1681699091d117af85ff59260cefc53c6d.zip
dev-ros/rqt_topic: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_topic')
-rw-r--r--dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild12
-rw-r--r--dev-ros/rqt_topic/rqt_topic-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild b/dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild
index 414b58def1e1..e99b6145b05f 100644
--- a/dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild
+++ b/dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild
@@ -14,11 +14,11 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/rostopic[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
- dev-ros/std_msgs[${PYTHON_USEDEP}]
- >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_SINGLE_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_topic/rqt_topic-9999.ebuild b/dev-ros/rqt_topic/rqt_topic-9999.ebuild
index 414b58def1e1..e99b6145b05f 100644
--- a/dev-ros/rqt_topic/rqt_topic-9999.ebuild
+++ b/dev-ros/rqt_topic/rqt_topic-9999.ebuild
@@ -14,11 +14,11 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/rostopic[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
- dev-ros/std_msgs[${PYTHON_USEDEP}]
- >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_SINGLE_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"