summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-19 14:55:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-19 15:07:21 +0200
commit36702bb4a138513888dbd89a4439f8e3b0d05c96 (patch)
treeada00fb577cfc38e50af7e03725a6054290d8723 /dev-ros/settlerlib/settlerlib-0.10.14.ebuild
parentdev-ros/monocam_settler: Bump to 0.10.14. (diff)
downloadgentoo-36702bb4a138513888dbd89a4439f8e3b0d05c96.tar.gz
gentoo-36702bb4a138513888dbd89a4439f8e3b0d05c96.tar.bz2
gentoo-36702bb4a138513888dbd89a4439f8e3b0d05c96.zip
dev-ros/settlerlib: Bump to 0.10.14.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/settlerlib/settlerlib-0.10.14.ebuild')
-rw-r--r--dev-ros/settlerlib/settlerlib-0.10.14.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/settlerlib/settlerlib-0.10.14.ebuild b/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
new file mode 100644
index 000000000000..e00b3046a233
--- /dev/null
+++ b/dev-ros/settlerlib/settlerlib-0.10.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helper functions and routines to help creating a settler for a specific sensor channel"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"