summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-18 16:40:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-18 16:59:36 +0100
commitc1d3d9342e8ec7f750ff34fa5469aa0d9d92c0b7 (patch)
tree0410396331d733a03e7337bc76e4b82e7cf8a9c8 /dev-ros/sound_play/sound_play-0.2.11.ebuild
parentdev-ros/audio_play: Bump to 0.2.11. (diff)
downloadgentoo-c1d3d9342e8ec7f750ff34fa5469aa0d9d92c0b7.tar.gz
gentoo-c1d3d9342e8ec7f750ff34fa5469aa0d9d92c0b7.tar.bz2
gentoo-c1d3d9342e8ec7f750ff34fa5469aa0d9d92c0b7.zip
dev-ros/sound_play: Bump to 0.2.11.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/sound_play/sound_play-0.2.11.ebuild')
-rw-r--r--dev-ros/sound_play/sound_play-0.2.11.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/sound_play/sound_play-0.2.11.ebuild b/dev-ros/sound_play/sound_play-0.2.11.ebuild
new file mode 100644
index 000000000000..c4b4cb101276
--- /dev/null
+++ b/dev-ros/sound_play/sound_play-0.2.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS node that translates commands on a ROS topic (robotsound) into sounds"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib
+ media-libs/gstreamer:0.10
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ app-accessibility/festival
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-base:0.10
+"