summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-28 15:04:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-28 15:04:30 +0200
commit14f28e795137ce7e399449767cbe1b91d2526f64 (patch)
treedfe3b0eac11ae200db5bf3587c9e4b76a4f534a7 /dev-ros/sound_play
parentdev-ros/audio_capture: Initial import. Ebuild by me. (diff)
downloadgentoo-14f28e795137ce7e399449767cbe1b91d2526f64.tar.gz
gentoo-14f28e795137ce7e399449767cbe1b91d2526f64.tar.bz2
gentoo-14f28e795137ce7e399449767cbe1b91d2526f64.zip
dev-ros/sound_play: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/sound_play')
-rw-r--r--dev-ros/sound_play/Manifest1
-rw-r--r--dev-ros/sound_play/metadata.xml5
-rw-r--r--dev-ros/sound_play/sound_play-0.2.7.ebuild35
-rw-r--r--dev-ros/sound_play/sound_play-9999.ebuild35
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-ros/sound_play/Manifest b/dev-ros/sound_play/Manifest
new file mode 100644
index 000000000000..aec3da0b587f
--- /dev/null
+++ b/dev-ros/sound_play/Manifest
@@ -0,0 +1 @@
+DIST audio_common-0.2.7.tar.gz 173982 SHA256 bdffab26cd837b6db65d275dd14de143d1cf056167fc121b213b7403142195c4 SHA512 f765422bdb641e87132e1c9c56ca742d6830fed1d7414b337b61aa242f9955e4138ab13ee4a7786c78ff73f5824748ceb38f98612a7f12dab4dcdc97efa289e3 WHIRLPOOL d1bf17f8bd0e8346d2fff48982c402b0eaa2ea4365b3195e3dd0c4943c93cf1935fdff85a0d2018e43e5074640692c3d72dc72887c86d955dc02c60800e3725b
diff --git a/dev-ros/sound_play/metadata.xml b/dev-ros/sound_play/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/sound_play/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/sound_play/sound_play-0.2.7.ebuild b/dev-ros/sound_play/sound_play-0.2.7.ebuild
new file mode 100644
index 000000000000..c4b4cb101276
--- /dev/null
+++ b/dev-ros/sound_play/sound_play-0.2.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS node that translates commands on a ROS topic (robotsound) into sounds"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib
+ media-libs/gstreamer:0.10
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ app-accessibility/festival
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-base:0.10
+"
diff --git a/dev-ros/sound_play/sound_play-9999.ebuild b/dev-ros/sound_play/sound_play-9999.ebuild
new file mode 100644
index 000000000000..c4b4cb101276
--- /dev/null
+++ b/dev-ros/sound_play/sound_play-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS node that translates commands on a ROS topic (robotsound) into sounds"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib
+ media-libs/gstreamer:0.10
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ app-accessibility/festival
+ media-libs/gst-plugins-good:0.10
+ media-libs/gst-plugins-base:0.10
+"