summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:17:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:17:02 +0200
commit8a2da7a2a9cbdf94ba0e7001d5605cd4416632b2 (patch)
tree45733046b536cc445c4eba7efee775329e6316bf /dev-ros/test_bond/test_bond-1.7.16.ebuild
parentdev-ros/bondpy: Initial import. Ebuild by me. (diff)
downloadgentoo-8a2da7a2a9cbdf94ba0e7001d5605cd4416632b2.tar.gz
gentoo-8a2da7a2a9cbdf94ba0e7001d5605cd4416632b2.tar.bz2
gentoo-8a2da7a2a9cbdf94ba0e7001d5605cd4416632b2.zip
dev-ros/test_bond: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/test_bond/test_bond-1.7.16.ebuild')
-rw-r--r--dev-ros/test_bond/test_bond-1.7.16.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/test_bond/test_bond-1.7.16.ebuild b/dev-ros/test_bond/test_bond-1.7.16.ebuild
new file mode 100644
index 000000000000..9ea825ecc3f7
--- /dev/null
+++ b/dev-ros/test_bond/test_bond-1.7.16.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for bond, bondpy and bondcpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/bondpy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"