summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:58:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:28 +0200
commit1367a4b1221648ab9f359ce085ae06c4bbcd1911 (patch)
treef9a169c0b0b426106f1b5b380e0252c455b44208 /dev-ros/test_rosbag/test_rosbag-9999.ebuild
parentdev-ros/roswtf: Initial import. Ebuild by me. (diff)
downloadgentoo-1367a4b1221648ab9f359ce085ae06c4bbcd1911.tar.gz
gentoo-1367a4b1221648ab9f359ce085ae06c4bbcd1911.tar.bz2
gentoo-1367a4b1221648ab9f359ce085ae06c4bbcd1911.zip
dev-ros/test_rosbag: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/test_rosbag/test_rosbag-9999.ebuild')
-rw-r--r--dev-ros/test_rosbag/test_rosbag-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/test_rosbag/test_rosbag-9999.ebuild b/dev-ros/test_rosbag/test_rosbag-9999.ebuild
new file mode 100644
index 000000000000..fd134828883f
--- /dev/null
+++ b/dev-ros/test_rosbag/test_rosbag-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_generation
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/topic_tools[${PYTHON_USEDEP}]
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/boost[threads]
+ app-arch/bzip2
+ dev-ros/rosout
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ )
+"