summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-14 11:51:01 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-14 12:38:20 +0100
commit90eb73ea116128ec1481458cf3cb0e1049c5b9ac (patch)
tree973813ee0717cfdef951ef5c3f2e78a01612a4c0 /dev-ros/test_rosmaster/test_rosmaster-1.11.17.ebuild
parentdev-ros/test_roslib_comm: Bump to 1.11.17. (diff)
downloadgentoo-90eb73ea116128ec1481458cf3cb0e1049c5b9ac.tar.gz
gentoo-90eb73ea116128ec1481458cf3cb0e1049c5b9ac.tar.bz2
gentoo-90eb73ea116128ec1481458cf3cb0e1049c5b9ac.zip
dev-ros/test_rosmaster: Bump to 1.11.17.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosmaster/test_rosmaster-1.11.17.ebuild')
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.11.17.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.11.17.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.11.17.ebuild
new file mode 100644
index 000000000000..66e52c1b5985
--- /dev/null
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.11.17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosmaster"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
+
+src_install() {
+ ros-catkin_src_install
+ dodir /usr/share/${PN}
+ cp -a test "${ED}//usr/share/${PN}/" || die
+}