summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-14 12:05:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-14 12:05:55 +0100
commitd5e2a4adc702196134a5f206a5c831a82f2ce25e (patch)
tree3685a16a824c621dd157486b69b6ea40dacba303 /dev-ros/test_rosparam/test_rosparam-1.11.16.ebuild
parentdev-ros/test_rosmaster: Bump to 1.11.16. (diff)
downloadgentoo-d5e2a4adc702196134a5f206a5c831a82f2ce25e.tar.gz
gentoo-d5e2a4adc702196134a5f206a5c831a82f2ce25e.tar.bz2
gentoo-d5e2a4adc702196134a5f206a5c831a82f2ce25e.zip
dev-ros/test_rosparam: Bump to 1.11.16.
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.11.16.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.11.16.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.11.16.ebuild b/dev-ros/test_rosparam/test_rosparam-1.11.16.ebuild
new file mode 100644
index 000000000000..7c14578e9162
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.11.16.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"