summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-19 14:26:29 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-19 14:56:43 +0100
commite8b4d3c09706e1062dc665da0f3d98f5fd2eaa6c (patch)
treeb1b215304a8061bb204a825cec13251fcfdd0993 /dev-ros/test_rosparam/test_rosparam-1.12.0.ebuild
parentdev-ros/test_rosmaster: Bump to 1.12.0. (diff)
downloadgentoo-e8b4d3c09706e1062dc665da0f3d98f5fd2eaa6c.tar.gz
gentoo-e8b4d3c09706e1062dc665da0f3d98f5fd2eaa6c.tar.bz2
gentoo-e8b4d3c09706e1062dc665da0f3d98f5fd2eaa6c.zip
dev-ros/test_rosparam: Bump to 1.12.0.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.12.0.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.12.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.12.0.ebuild b/dev-ros/test_rosparam/test_rosparam-1.12.0.ebuild
new file mode 100644
index 000000000000..7c14578e9162
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.12.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"