summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-01 13:44:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-01 13:53:54 +0100
commit23c71845019f7a246b5b7f762b82bff6238d76d0 (patch)
treebffb8e33d22c1688ba1acb6cdd119ad9bbcb4a80 /dev-ros/test_rosparam/test_rosparam-1.12.6.ebuild
parentdev-ros/test_rosmaster: Bump to 1.12.6. (diff)
downloadgentoo-23c71845019f7a246b5b7f762b82bff6238d76d0.tar.gz
gentoo-23c71845019f7a246b5b7f762b82bff6238d76d0.tar.bz2
gentoo-23c71845019f7a246b5b7f762b82bff6238d76d0.zip
dev-ros/test_rosparam: Bump to 1.12.6.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.12.6.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.12.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.12.6.ebuild b/dev-ros/test_rosparam/test_rosparam-1.12.6.ebuild
new file mode 100644
index 000000000000..49ec6da5c1bf
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.12.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"