summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 13:05:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:54 +0200
commit256d6e5dfb262294ef3cfce6c4e287893ab10b51 (patch)
treec81b3e9c1c1d8f1288eac076e39debbd1c5879d0 /dev-ros/test_rospy/test_rospy-1.14.2.ebuild
parentdev-ros/test_rosparam: Bump to 1.14.2. (diff)
downloadgentoo-256d6e5dfb262294ef3cfce6c4e287893ab10b51.tar.gz
gentoo-256d6e5dfb262294ef3cfce6c4e287893ab10b51.tar.bz2
gentoo-256d6e5dfb262294ef3cfce6c4e287893ab10b51.zip
dev-ros/test_rospy: Bump to 1.14.2.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.14.2.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.14.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.14.2.ebuild b/dev-ros/test_rospy/test_rospy-1.14.2.ebuild
new file mode 100644
index 000000000000..c681d244b919
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.14.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"