summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-31 07:57:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-31 11:10:12 +0200
commit345becc09a286d5de8c9e47394c846d7cd30b405 (patch)
tree0bec1e77605f40e71f9e53e36d70563fde9282b0 /dev-ros/tf2_py/tf2_py-0.7.3.ebuild
parentdev-ros/tf2_msgs: Bump to 0.7.3. (diff)
downloadgentoo-345becc09a286d5de8c9e47394c846d7cd30b405.tar.gz
gentoo-345becc09a286d5de8c9e47394c846d7cd30b405.tar.bz2
gentoo-345becc09a286d5de8c9e47394c846d7cd30b405.zip
dev-ros/tf2_py: Bump to 0.7.3.
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf2_py/tf2_py-0.7.3.ebuild')
-rw-r--r--dev-ros/tf2_py/tf2_py-0.7.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/tf2_py/tf2_py-0.7.3.ebuild b/dev-ros/tf2_py/tf2_py-0.7.3.ebuild
new file mode 100644
index 000000000000..2bae9efadc93
--- /dev/null
+++ b/dev-ros/tf2_py/tf2_py-0.7.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 python bindings"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"