summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:30:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:20 +0200
commit8a24dec447e546f0e3f76276f9ed4d0ddcde99db (patch)
tree8797575b505422feedb73cf112e159573fd6e766 /dev-ros/tf2_py
parentdev-ros/tf2: Initial import. Ebuild by me. (diff)
downloadgentoo-8a24dec447e546f0e3f76276f9ed4d0ddcde99db.tar.gz
gentoo-8a24dec447e546f0e3f76276f9ed4d0ddcde99db.tar.bz2
gentoo-8a24dec447e546f0e3f76276f9ed4d0ddcde99db.zip
dev-ros/tf2_py: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/tf2_py')
-rw-r--r--dev-ros/tf2_py/Manifest1
-rw-r--r--dev-ros/tf2_py/metadata.xml5
-rw-r--r--dev-ros/tf2_py/tf2_py-0.5.12.ebuild22
-rw-r--r--dev-ros/tf2_py/tf2_py-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ros/tf2_py/Manifest b/dev-ros/tf2_py/Manifest
new file mode 100644
index 000000000000..ec008bbcd231
--- /dev/null
+++ b/dev-ros/tf2_py/Manifest
@@ -0,0 +1 @@
+DIST geometry_experimental-0.5.12.tar.gz 131234 SHA256 430115ef4a3352e8b00596ff7406e6cb14fc1720250cf164754cf724c7f371c3 SHA512 1a1a33db529d0810661c020552642d914de01a14e5b17b611fb7743a795c47e3f68d480ee4544b4ad86f7b1c947ea8b23cda09535ce046fdc45da1c40fc34711 WHIRLPOOL fd894a43e0110eeab1f085faa32a339a72d922d57ae68ee82c2b54f73c246090f3537483f1ca68147f5b7b7a5c7502f9fd4ab733da150c68af94ea2d87859ab1
diff --git a/dev-ros/tf2_py/metadata.xml b/dev-ros/tf2_py/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/tf2_py/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/tf2_py/tf2_py-0.5.12.ebuild b/dev-ros/tf2_py/tf2_py-0.5.12.ebuild
new file mode 100644
index 000000000000..aaa13254f691
--- /dev/null
+++ b/dev-ros/tf2_py/tf2_py-0.5.12.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 python bindings"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/tf2_py/tf2_py-9999.ebuild b/dev-ros/tf2_py/tf2_py-9999.ebuild
new file mode 100644
index 000000000000..aaa13254f691
--- /dev/null
+++ b/dev-ros/tf2_py/tf2_py-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 python bindings"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"